Jump to content
aspenarb

Fings wot broke

Recommended Posts

Have u checked the bearings to see if theres any movment.any impact on the anvils.

Yeah all good, been out this week

 

Sent from my SM-N910F using Arbtalk mobile app

Share this post


Link to post
Share on other sites

Telehandler has had a bit of a run and needed a bit of love.

 

Pin retainer on the beak fell out allowing the grab ram to push on the squiff.

 

Pushed out the side of the grab carriage, Mick fixed it with the hot spanner.

 

image_zpsdgp7i45s.jpg

 

Ram got bent so binned it and put another on there.

 

image_zps1t3j5zze.jpg

 

Spun up some new bushes for the grab

 

image_zpsxxaxq293.jpg

 

And had to make a new prop brake disc, this one got mashed on a stump.

 

image_zps2nkwrvqn.jpg

 

Found a dry UJ on the prop, its one of those that despite being greased only gets lubed on two of the cups :thumbdown:

 

image_zpsj6vyzwl1.jpg

 

Found the reason it had lost high range, a wire had ripped off.

 

image_zpstyldsero.jpg

 

All done and back at work :thumbup1:

 

image_zpsmaqes9hb.jpg

Share this post


Link to post
Share on other sites
What model is that bob? Seen a nice jcb 527-67 for sale

 

FDI Sambron Chris, excellent bit of old school telehandler.

 

Bob

Share this post


Link to post
Share on other sites
FDI Sambron Chris, excellent bit of old school telehandler.

 

Bob

 

like hens teeth now tho, i have to make do wi a manitou :laugh1:

Share this post


Link to post
Share on other sites
FDI Sambron Chris, excellent bit of old school telehandler.

 

Bob

 

Not heard of them up to now.

 

Heard the jcb's i mentioned like to set on fire on after some research i did lol :lol: shame as looked a nice machine

Share this post


Link to post
Share on other sites

ms201t tcm ,decided to break it top handle, cheaper to replace the complete handle than fk about trying to fix it ,:laugh1:

IMG_20170506_141833.jpg.17a26f50a9fa956c136ca1799a2e10c1.jpg

IMG_20170506_141832.jpg.dd4f7c4a76f62069f5feb1f1409b2e4b.jpg

Share this post


Link to post
Share on other sites

The parts are cheap enough John but there frustrating little thing to fix.

 

Sent from my SM-N910F using Arbtalk mobile app

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Featured Adverts

About

Arbtalk.co.uk is a hub for the arboriculture industry in the UK.  
If you're just starting out and you need business, equipment, tech or training support you're in the right place.  If you've done it, made it, got a van load of oily t-shirts and have decided to give something back by sharing your knowledge or wisdom,  then you're welcome too.
If you would like to contribute to making this industry more effective and safe then welcome.
Just like a living tree, it'll always be a work in progress.
Please have a look around, sign up, share and contribute the best you have.

See you inside.

The Arbtalk Team

Follow us

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.