Jump to content
GLynch

Ford ranger specialist needed

Recommended Posts

I have a 2008 ranger wildtrack 3.0

 

It's started making kind of a whoosh under engine breaking as in going from 3rd to 2nd gear 

 

Also when reversing up a slope it's makes a horrible squeaking kind of noise 

 

Looking for someone that specialises in rangers preferably in the bromsgrove be area or surrounding areas 

 

The truck has only just done 80,000 miles and seems to be in good overall condition so would like to have it running properly 

 

It all drives fine at the minute but would rather get it sorted before it gets worse 

 

Thanks 

 

 

 

 

Share this post


Link to post
Share on other sites

A guess that the squeak in reverse up a slope could be a prop shaft universal joint on the way out. The more extreme angle of approach through reversing uphill will exacerbate the bend of the UJ, hence it letting you know through the noises it’s making.

  • Like 2

Share this post


Link to post
Share on other sites

I had similar on my ranger, it was so long ago but I’m 99% sure that changing the uj sorted it. Get underneath and give it a wobble to check for play. 

Edited by doobin

Share this post


Link to post
Share on other sites
On 23/06/2021 at 09:18, GLynch said:

I wouldn't know what to look for tbh in m no good with vehicles 

Thanks for the info though

With it parked up and the handbrake on, engine off and out of gear grab each side of the flexible joints (universal joints-UJ's) on the driveshaft and try to rotate each side in opposite directions back and forth. If it's got play in it or its clunking then get it checked by a garage. 

Share this post


Link to post
Share on other sites
On 21/06/2021 at 08:03, GLynch said:

I have a 2008 ranger wildtrack 3.0

 

It's started making kind of a whoosh under engine breaking as in going from 3rd to 2nd gear 

 

Also when reversing up a slope it's makes a horrible squeaking kind of noise 

 

Looking for someone that specialises in rangers preferably in the bromsgrove be area or surrounding areas 

 

The truck has only just done 80,000 miles and seems to be in good overall condition so would like to have it running properly 

 

It all drives fine at the minute but would rather get it sorted before it gets worse 

 

Thanks 

 

 

 

 

The " woosh " noise could be a tubo hose leaking ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Featured Adverts

  • Tip site reviews

About

Arbtalk.co.uk is a hub for the arboriculture industry in the UK.  
If you're just starting out and you need business, equipment, tech or training support you're in the right place.  If you've done it, made it, got a van load of oily t-shirts and have decided to give something back by sharing your knowledge or wisdom,  then you're welcome too.
If you would like to contribute to making this industry more effective and safe then welcome.
Just like a living tree, it'll always be a work in progress.
Please have a look around, sign up, share and contribute the best you have.

See you inside.

The Arbtalk Team

Follow us

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.