Jump to content
hesslemount

GreenMech 160 QuadChip no power

Recommended Posts

Hi Guys

I can’t start my chipper. Closer inspection shows Ive a brown (+v) and a blue (0V) with red terminals that aren’t plugged into anything. They come from the RDS Junction plus Control Box (PL3) and belong to the “power switch “. I can’t for the life of me see where they plug into on the actual chipper! I’ve included 2 photos to assist. Any help greatly appreciated. 

 

https://greenmech.co.uk/wp-content/uploads/TechDocs/QuadTrak 160 MK2 Manual.pdf

 

See page 42

A1E4C06A-678D-4510-86E9-C4DC45A675FC.jpeg

B458C688-949C-493D-BAE7-6F759CD3AFF4.jpeg

18829D4D-341B-4B3E-8C74-EE1A501A8B16.png

Share this post


Link to post
Share on other sites

BTW, there should be three terminals on the ignition switch , one in the middle and two outer terminals. Connect one wire to the middle terminal and the other wire to one of the outer terminals , it doesn’t matter which wire goes to which terminal..

Jase..

 

Oh yeah , there’s something big coming soon from GreenMech , just in case you haven’t heard the rumour..😎

  • Like 1

Share this post


Link to post
Share on other sites

That makes perfect sense. I’m guessing just behind the switch? Is it normal for both terminals to come loose? Many thanks BTW. What’s the rumour?

Share this post


Link to post
Share on other sites
11 minutes ago, hesslemount said:

That makes perfect sense. I’m guessing just behind the switch? Is it normal for both terminals to come loose? Many thanks BTW. What’s the rumour?

No it's unusual and hopefully neither has shorted out to earth as that could possibly blow the circuit board..

Rumour , what rumour..? 😉

Share this post


Link to post
Share on other sites
11 minutes ago, hesslemount said:

Also is there a decent solution to prevent the terminals coming loose again?

You could just try squashing the red terminals with a pair of pliers to close them up a bit or if you have spare terminals and crimping pliers , replace them ?

Don't let either wire short to earth though..

Jase..

Share this post


Link to post
Share on other sites

ImageUploadedByArbtalk1579079851.887855.jpg

I see 4 terminals three on the circumference and one more central. Shall I opted for a centre of the three and another one side of that?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Featured Adverts

About

Arbtalk.co.uk is a hub for the arboriculture industry in the UK.  
If you're just starting out and you need business, equipment, tech or training support you're in the right place.  If you've done it, made it, got a van load of oily t-shirts and have decided to give something back by sharing your knowledge or wisdom,  then you're welcome too.
If you would like to contribute to making this industry more effective and safe then welcome.
Just like a living tree, it'll always be a work in progress.
Please have a look around, sign up, share and contribute the best you have.

See you inside.

The Arbtalk Team

Follow us

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.